No puedo instalar Xcode en mi Mac?

Quiero instalar metasploit, y sé que se necesita xcode. Ahora el problema es que, aunque xcode está en mi computadora y lo descargué de la tienda de aplicaciones, esto ocurre:

./msf_install.sh -i -p msfconsole -r [*] Log file with command output and errors /tmp/msfinstall-Oct-03-15-003057.log [*] Verifying that Development Tools and Java are installed: [*] Java is installed. [*] Xcode is not installed on this system. Install from the Apple AppStore. 

Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).