No se puede conectar a localhost en mi máquina de desarrollo

Estoy configurando una nueva máquina de desarrollo web utilizando la guía muy completa y bien escrita publicada por Echo Software, pero no puedo conectarme a localhost después de seguir / verificar cada paso. Mis únicos cambios fueron usar PHPv7.0 en lugar de 5.6 y deshabilitar el modo estricto de MySQL porque algunos progtwigs de terceros que necesito ejecutar requieren reglas más flexibles.

Puedo hacer ping a los dominios 127.0.0.1 , localhost y *.dev éxito (los tres commands devuelven exactamente el mismo resultado):

 $ ping -c1 127.0.0.1 $ ping -c1 localhost $ ping -c1 test.dev PING 127.0.0.1 (127.0.0.1): 56 data bytes 64 bytes from 127.0.0.1: icmp_seq=0 ttl=64 time=0.092 ms --- 127.0.0.1 ping statistics --- 1 packets transmitted, 1 packets received, 0.0% packet loss 

Sin embargo, todavía no puedo conectarme con ninguno de ellos a través de HTTP (los mismos resultados cuando uso Safari Chrome o Firefox):

 $ curl http://localhost curl: (7) Failed to connect to localhost port 80: Connection refused 

He afirmado que Apache, PHP y dnsMasq se ejecutan ejecutando la brew services list , y que todos están configurados correctamente:

 $ brew services list Name Status Plist dnsmasq started /Users/{mysusername}/Library/LaunchAgents/homebrew.mxcl.dnsmasq.plist httpd22 started /Users/{mysusername}/Library/LaunchAgents/homebrew.mxcl.httpd22.plist mysql started /Users/{mysusername}/Library/LaunchAgents/homebrew.mxcl.mysql.plist php70 started /Users/{mysusername}/Library/LaunchAgents/homebrew.mxcl.php70.plist $ apachectl -v Server version: Apache/2.2.31 (Unix) $ apachectl -t Syntax OK $ php -v PHP 7.0.10 (cli) (built: Aug 21 2016 19:14:33) ( NTS ) 

No veo el puerto 8080 en la list cuando ejecuto un escaneo de puertos en 127.0.0.1, pero como entiendo, es autoformado por pf .

Ya tengo:

  • Comtesting mi /etc/hosts : no ha sido manipulado.
  • Inhabilitado mi firewall: sin cambios en absoluto.
  • Verifique dos veces cada paso de la guía.
  • Seguí la misma guía dos veces hace unos meses: ahora ambas máquinas están contentas.
  • Lea cada pregunta / respuesta similar que pude encontrar, pero ninguna ayudó.
  • Busqué salida en los files de logging de Apache y PHP: nada allí tampoco.
  • Se acabó la hipótesis …

¡Cualquier ayuda sería bienvenida!


Editar: También tengo la rbenv y docker/docker-compose en la máquina, espero que no esté en conflicto porque también los necesito a los dos.

Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).