¿Por qué los altavoces internos de mi Macbook no están disponibles?

Mi Macbook (la versión de aluminio unibody) ha perdido sus parlantes internos. Cuando abro Preferences del sistema -> Sonido -> Salida, todo lo que veo es "Salida digital". Si enchufo un par de auriculares, esto cambia a "Auriculares". No veo "Interlocutores Internos" para nada más. Los auriculares parecen funcionar bien.

En System Profiler -> Audio -> Dispositivos disponibles, veo "Speaker: Connection: Internal".

Acabo de instalar Snow Leopard limpio, por lo que parece ser un problema de hardware.

¿Hay algo que pueda hacer para solucionar esto, salvo devolverlo a Apple? Está fuera de garantía.

  • ¿Por qué un file .DS_Store sigue apareciendo en el escritorio?
  • Pantalla externa en MacBook Pro Retina (Mountain Lion) permanece en blanco después del time de espera de la pantalla o al despertar del modo de suspensión
  • Comprender la asignación de memory activa, inactiva, libre y de intercambio
  • Sonido y calor cuando la tapa está cerrada - MacBook Air
  • ¿Qué está causando la alta carga de CPU del sistema bajo Mountain Lion?
  • ¿El MacBook Air de principios de 2014 usa Thunderbolt 1 o Thunderbolt 2?
  • MacOS High Sierra se reinicia solo durante el sueño
  • ¿Puedo usar mi macbook air de 128 GB para ejecutar temporalmente una copy de security de 512 GB / 1TB?
  • 3 Solutions collect form web for “¿Por qué los altavoces internos de mi Macbook no están disponibles?”

    Si miras en el conector de auriculares, ¿hay una luz roja encendida?
    En caso afirmativo, entonces tiene la salida digital activada, y esto complica la configuration de los altavoces.

    Hay un hilo aquí , que tiene algunas correcciones posibles.

    Actualización Hay un interruptor dentro del conector que está atascado. Enchufe el conector de altavoz varias veces mientras observa el panel de preferences del sistema de salida de sonido. La opción del altavoz interno se encenderá si el interruptor se despega.

    Tomar un palillo de dientes y juguetear dentro del gato ha resuelto el problema para algunos, debe intentar esto. (No rompa el palillo dentro :))

    De: http://forums.macrumors.com/showthread.php?t=239287

    El problema es causado por un pequeño interruptor dentro del gato que se atasca. Cuando conectas un cable de audio, empuja el interruptor hacia abajo. Si se trata de un cable analógico, el extremo está hecho de metal. Si es óptico, el extremo está hecho de plástico. Si se presiona el interruptor hacia abajo, la computadora verifica si el enchufe en el interior es de metal o plástico en function de la conductividad. Cuando se queda atascado y no hay nada allí, cree que un cable óptico está enchufado porque el interruptor está apagado pero no hay nada conductor allí. Es por eso que funciona con auriculares o parlantes analógicos externos.

    Al igual que aquí, enchufé mis auriculares y los sacudí un poco mientras estaba dentro y luego los saqué a la mitad. Una vez que lo hice, pude ver que el control deslizante de volumen aparecía y el volumen se podía ajustar hacia arriba y hacia abajo. Los saqué por completo y el volumen se volvió gris otra vez. Volvió a colocar los auriculares y luego los sacó y ahora todo está bien.

    Tuve este problema y lo solucioné conectando (y luego desconectando) los auriculares de mi iPod.

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).