Soundflower + AU Lab + Mavericks produce un clic incesante

He dirigido con éxito el audio de mi sistema a través de AU Lab a través de Soundflower, pero hace clic.

Que yo sepa, ese sonido de clic generalmente significa que los tamaños de los búfers están fuera de wack (ya sea demasiado pequeños o no son consistentes en todas las aplicaciones en la cadena de señal).

Sin embargo, tratar de hacer coincidir las configuraciones de la siguiente manera no parece solucionar el problema.

Mi configuration:

• En Soundflowerbed, tamaño del buffer = 2048
• En el panel de información para AU Lab (CMD + i), seleccionado 'Abrir en modo de 32 bits'
• En las preferences de AU Lab, el tamaño del búfer de todos los dispositivos = 2048
• En System Prefs> Audio Midi Setup, formatting de salida incorporada = 44.1k, 32 bits, para que coincida con Soundflower.

Algunas observaciones:

• En AU Lab, independientemente de la configuration que haya seleccionado en Preferences, muestra que la configuration de Marcos de salida incorporada es 512, que no es necesariamente lo que tengo configurado. Esa figura se actualiza para Soundflower. No estoy seguro de qué se trata.

• Establecer todos los tamaños de búfer en 512 para que coincidan con los de arriba tampoco soluciona el problema.

• El clic está presente con todo el audio, consistentemente, y comienza tan pronto como comienza el audio. Si no hay audio, no hay clic.

• En la configuration de audio Midi, Soundflower dice que su audio es de la variedad de integers de 32 bits, mientras que la opción más cercana de salida incorporada es flotación de 32 bits. No sé lo suficiente sobre el procesamiento de señal digital para saber si eso es un problema.

Estoy en el model MBP de mediados de 2014 con OSX 9.4, Soundflower 1.6.6 y AU Lab 2.3.

  • Cómo detener el audio de "warbling" cuando se usa SoundFlower
  • Transmita videos y sonidos diferentes a los auriculares y altavoces Bluetooth
  • OS X El Capitan no se encontró dispositivo de salida de sonido
  • Cómo grabar el audio del sistema? (Soundflower no funciona)
  • ¿Cómo uso Soundflower con El Capitan en mi MacBook Air y escucho el audio de mi computadora mientras grabo con QuickTime?
  • Permitiendo permanentemente el control de volumen para la interfaz de audio que no lo admite
  • ¿Cómo envío el audio de YouTube a AU Lab usando SoundFlower?
  • ¿Cómo compartir audio de Mac a través de Skype con el micrófono?
  • 7 Solutions collect form web for “Soundflower + AU Lab + Mavericks produce un clic incesante”

    Soundsiphon también lo resolvió por mí. No es necesario que compre la versión Pro, ya que la captura de audio de todo el sistema (lo que significa que ninguna aplicación específica como safari debe seleccionarse como fuente de audio) es gratuita. 🙂

    Mi configuration: soundsiphon como dispositivo de audio del sistema pnetworkingeterminado: enter image description here

    cualquier reproductor de audio / fuente en OS Yosemite -> AU Lab 2.2.2 (IN soundsiphon -> Waves GEQ -> OUT FiiO DAC: enter image description here

    Perdón por las pantallas alemanas 🙂

    Solucioné el problema permanentemente 0 clics el 100% del time.

    Tengo MacBook Air a mediados de 2013, OSX Yosemite AU Lab 2.3.1 Sifón de sonido http://staticz.com/soundsiphon/

    El sifón de sonido es un progtwig de reemploop para Soundflowerbed. Hace el mismo trabajo. creo que es gratis? la demostración se está ejecutando ahora, pero parece que no me dice los días restantes.

    Voy a ir a correr la voz ahora.

    Es exactamente lo mismo aquí, haciendo clic periódicamente, aproximadamente 3 veces por segundo. Suena como desertores. No creo que haya nada que podamos hacer: / He tenido exactamente la misma configuration funcionando perfectamente en versiones anteriores de OX, incluso Mavericks si no recuerdo mal. Apple lo rompió con 10.9.4. Y cuando miras la date de la versión pública, 2.2.2 … es de 2012. 2.3 no es pública (¿beta?) Y tampoco funciona. Obviamente, no es una prioridad para Apple.

    En mi sistema, no hace clic de inmediato, solo después de un time. Hay un puñado de soluciones temporales que a veces me funcionan:

    • Cerrando y volviendo a abrir AU Lab y la aplicación que está reproduciendo el sonido

    • En AU Lab, en "Ventana" -> "Mostrar estudio", luego cambie los canales de input y salida, "aplique cambios de canal", vuelva a los canales correctos, vuelva a aplicar.

    La última solución solía funcionar todo el time, ahora no es así. Es todo súper aleatorio y frustrante. Realmente necesito que funcione, porque estoy usando un plugin de corrección acústica. Ahora estoy jugueteando con AU Lab 30 veces al día.

    Una observación final: Ciertas aplicaciones tienen muchas más probabilidades de comenzar a hacer clic. El más probable es el contenido de Safari, Soundcloud en particular. La desactivación de la memory caching de Safari no ayudó (para ser sincero, no tengo idea de por qué debería cambiar algo, simplemente bash todo).

    Información del sistema: Mac Mini i5 2011, 16 GB Ram, 512 GB 840 Evo SSD, OSX 10.9.4, AU Lab 2.3, Soundflower v1.6.6, Motu 828 Mk1

    La solución del usuario Carmine Paulino en Github resolvió el problema. Lo encontró a través de su respuesta en otra pregunta . Su actualización también agrega algunos elementos agradables de UI al menu desplegable de Soundflowerbed, que se muestra a continuación.

    Captura de pantalla del menú desplegable para la actualización Soundflower de Carmine Paulino

    Todavía hace clic brevemente cuando se despierta de la suspensión si hay reproducción de audio, pero eso se resuelve sin ningún trabajo de mi parte. ¡Gran éxito!

    ¡Me alegro de que esté funcionando para ti! Soundflower 1.6.7 no cambia nada en mi sistema sin embargo.

    Aunque podría tener que forzar la reconstrucción de las extensiones del núcleo, recientemente leí que ocasionalmente las extensiones antiguas no se descargan correctamente cuando las actualizas.

    Tengo exactamente el problema descrito anteriormente: con Yosemite, todas las versiones más recientes de todo, modo de 64 bits, 2048 cuadros, etc. Me he cansado de todos los arreglos, me he equivocado con todos los parameters y todavía tengo un ruido persistente y sobrecargas. de AU Lab, incluso cuando no se ejecutan otras aplicaciones Y no hay efectos o complementos en absoluto. Simplemente ejecutando audio a través de SoundFlower -> AU Lab lo estropea.

    Entonces, supongo, algo profundamente erróneo en CoreAudio. Muy frustrante ya que dedico mucho time a los perfiles RTA EQ utilizando AU Lab.

    Mi trabajo por el momento es usar Adobe Audition for EQ. Ejecute audio a través de una session ficticia de múltiples pistas, monitoree una pista estéreo y use un EQ Effect. Overkill, pero funciona bien, y puedes jugar a ajustar la mezcla húmeda / seca, lo que es bueno.

    Bajé el volumen de salida en las preferences del sistema, luego aumenté el volumen en mi amplificador externo … esto resolvió el problema para mí. ^ _ ^

    Loving Apple Products like poisoning (iPhone, iPad, iMac, Macbook, iWatch).